Registrar Registry Manager

RootKit Hook Analyzer
for Windows XP/2000/2003

Copyright © 2005 Resplendence Software Projects Sp. All rights reserved.
http://www.resplendence.com


Introduction

Product Description

RootKit Hook Analyzer is a security tool which will check if there are any rootkits installed on your computer which hook the kernel system services. Kernel RootKit Hooks are installed modules which intercept the principal system services that all programs and the operating system make use of. If any of these system services is modified it means that there is a possibility that the safety of your system is at risk.

Are kernel hooks always bad ?

Kernel hooks are out of fashion these days and are not officially documented and considered deprecated by Microsoft. The pioneering heroes of the old days who discovered how to actually implement them have all adapted to the new fashion to advice against using kernel hooks as a programming practice. Often kernel hooks are unnecessary and there are documented ways which allow a programmer to achieve his goal instead. However in a lot of system tools such as monitoring and antivirus software, kernel hooks are the only available technique to get the trick done and thus are an unavoidable necessary evil. Important is that if your kernel system services are hooked that you can find out which is the responsible software that makes use of this technique. Inspired by all the discussions going on about the Sony CD protection rootkit, we have developed the RootKit Hook Analyzer.

RootKit Hook Analyzer will tell you what kernel hooks are active on your system. It displays all kernel system services along with their base addresses responsible module as well as product name, company and module description. If no hooks are active on your system it means that all system services are handled by NTOSKRNL.EXE, the principal base component of most Windows operating systems which is developed by Microsoft.

All you have to do to find out what hooks are installed on your system is press the Analyze button at the bottom of the screen. RootKit Hook Analyzer also allows you to view installed system modules and drivers with their base address as well as file and product information and responsible company.


System Requirements

RootKit Hook Analyzer requires a PC running one of the following operating systems:

  • Windows XP Home Edition
  • Windows XP Professional
  • Windows 2003 Server
  • Windows 2000 Server
  • Windows 2000 Workstation

The software requires that you are logged on with administrator rights.
Because the 64 bit editions of Microsoft Windows have built-in protection against hooking of system call services, RootKit Hook Analyzer will not work on this operating system.


Contact and Ordering Info

Support and Contact Info

Technical Support

If you wish to submit a bug report, suggestion or other comment then please fill in the form at our website:
http://www.resplendence.com/support

You can contact us at the following address:

Resplendence Software Projects Sp.
Via Hanoi 3
40052, Baricella
Italy
Tel: +39 340 2742348
Fax: +31 84 8768066
email: info@resplendence.com
web: http://www.resplendence.com